[动态规划][树形dp]Anniversary party

2018-08-02 05:44:00来源:博客园 阅读 ()

新老客户大回馈,云服务器低至5折

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

思路:树形dp;定义状态dp[i][0]表示编号为i的员工不来时,以他为根的子树所能获得的最大rating和;dp[i][1]表示编号为i的员工来时,以他为根的子树所能获得的最大rating和;
状态转移方程为dp[i][0]=sum{max(dp[j][0],dp[j][1]),j为i的直接下属},dp[i][1]=rating[i]+sum{dp[j][0],j为i的直接下属};
AC代码:
#include <iostream>
#include <cstdio>
using namespace std;

int dp[6010][2];
int fa[6010];
int n;

void dfs(int root){
   for(int i=1;i<=n;i++){
      if(i==root) continue;
      if(fa[i]==root) {
        dfs(i);
        dp[root][1]+=dp[i][0];
        dp[root][0]+=max(dp[i][1],dp[i][0]);
      }
   }
}

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++) fa[i]=i,scanf("%d",&dp[i][1]);
    int x,y;
    while(scanf("%d%d",&x,&y)&&(x||y)) fa[x]=y;
    int root=1;
    while(fa[root]!=root) root=fa[root];//找到整棵树的根节点
    dfs(root);
    printf("%d\n",max(dp[root][0],dp[root][1]));
    return 0;
}

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:c++编写递归函数char *itostr (int n,char *string),该函数将整

下一篇:C++编写字符串类CNString,该类有默认构造函数、类的拷贝函数、