hdu-1338 game predictions(贪心题)

2018-08-21 05:28:25来源:博客园 阅读 ()

新老客户大回馈,云服务器低至5折

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game. 
Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 

InputThe input consists of several test cases. The first line of each case contains two integers m (2 <= m <= 20) and n (1 <= n <= 50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros. 
OutputFor each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 
Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4

题意:模拟打牌,m个人,每人n张牌。点数1-n*m,出得最大的那个人赢一局,问你最多赢几局

题解:贪心,我出大的,对面出最小的,我出小的,对面最小但比我大的



#include<iostream>
#include<algorithm>
#include<cstring>
#include<sstream>
#include<cmath>
#include<cstdlib>
#include<queue>
using namespace std;
#define PI 3.14159265358979323846264338327950
bool a[1050];
int main()
{
    int m=0,n=0,count=0,t;
    while(scanf("%d %d",&m,&n) && (m||n))
    {
        count++;
        int i=0;
        int win=0,big=0;
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
        {
            scanf("%d",&t);
            a[t]=1;
        }
        for(i=n*m;i>0;i--)
        {
            if (a[i])
            {
                if (big==0)
                    ++win;
                else
                    big--;
            }
            else
                big++;
        }
        printf("Case %d: %d\n",count,win);
    }
    return 0;
}

 

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:P1288 取数游戏II

下一篇:4 Values whose Sum is 0 POJ - 2785