POJ1852

2019-11-11 09:00:29来源:博客园 阅读 ()

新老客户大回馈,云服务器低至5折

POJ1852

题目链接:http://poj.org/problem?id=1852

题目表述:

Ants
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 33151   Accepted: 12362

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

Waterloo local 2004.09.19 思路:即求出最大值与最小值即可,最小值就是每个蚂蚁离某一端取最近的,然后在每个最近中选择时间需要最多的那个蚂蚁。注意每个蚂蚁是同时进行运动的。 要求时间最大值时,题目描述说,当两个蚂蚁相遇时,只能各自掉头返回,我们在求最大值时,可以把蚂蚁视作无视相遇,照常穿过,同样也可以求出最大值,即取所需时间最多的那个蚂蚁的时间即可。   代码如下:
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    int n,l,t;
    cin >> t;
    while(t--)
    {
        int min1 = 0,max1 = 0,x;
        cin >> l >> n;
        for(int i = 0;i < n;i++)
        {
            cin >> x;
            if(x <= l / 2)
            {
                min1 = max(min1,x);
                max1 = max(max1,l - x);
            }
            else
            {
                min1 = max(min1,l - x);
                max1 = max(max1,x);
            }
        }
        cout << min1 << " " << max1 << endl;
    }
    return 0;
}

 


原文链接:https://www.cnblogs.com/biaobiao88/p/11832757.html
如有疑问请与原作者联系

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:160. 相交链表

下一篇:CUDA 编程相关;tensorflow GPU 编程;关键知识点记录;CUDA 编