hdu1062 text reverse

2020-01-27 16:00:43来源:博客园 阅读 ()

新老客户大回馈,云服务器低至5折

hdu1062 text reverse

 咳咳,这个是为了赶量

需要注意的就是输入方式,别的也没什么难点

Problem Description Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.  

 

Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.  

 

Output For each test case, you should output the text which is processed.  

 

Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
 

 

Sample Output
hello world!
I'm from hdu.
I like acm.
这是题意
接下来放代码

#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;

int main(){
int n;
cin >> n;
getchar();
while(n--){
stack<char>cst;
while(1){
int ch=getchar();
if(ch==' '||ch=='\n'){
while(!cst.empty()){
cout << cst.top();
cst.pop();
}
if(ch==' ')cout << ' ';
else break;
}
else cst.push(ch);
}
cout << endl;
}
return 0;
}

OK


原文链接:https://www.cnblogs.com/sos3210/p/12236034.html
如有疑问请与原作者联系

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:快速幂与矩阵快速幂

下一篇:C++读入优化