IDEA-Maven项目的jdk版本设置

2019-09-02 09:44:45来源:博客园 阅读 ()

IDEA-Maven项目的jdk版本设置

在 Intellij IDEA 中,我们需要设置 Settings 中的 Java Compiler 和 Project Structure 中的 Language Level 中的 jdk 版本为自己目前使用的版本,否则会经常提示我们 jdk 版本不正确导致的语法错误。在 Maven 项目中,jdk 的配置也有一些额外需要注意的地方。

比如配置为 jdk1.8 :

JavaCompiler

LanguageLevel

但是在 Maven 项目中,Java Compiler 和 Language level 中的设置会自动变回到 pom.xml 文件中设置的 jdk 版本或者默认的 jdk1.5 版本。所以我们需要在 pom.xml 文件中修改 jdk 版本的配置或者自己添加配置:

<!-- 这里一般有 maven 的默认配置,修改即可 -->
<properties>
    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
 </properties>

或者:

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.7.0</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

注意: 如果 properties 和 build 里面都有配置的话,那么 properties 会覆盖掉 build 里面的配置,即以 properties 里面的配置为准。

PS:如果觉得文章有什么地方写错了,哪里写得不好,或者有什么建议,欢迎指点。

欢迎您的点赞、收藏和评论!
(完)


原文链接:https://www.cnblogs.com/deecyn/p/11442119.html
如有疑问请与原作者联系

标签:IEAVQPS版本文件

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:PlayJava Day001

下一篇:Failed to configure a DataSource: &#39;url&#39; attr