Invariant Violation: requireNativeComponent: …

2019-08-14 10:16:21来源:博客园 阅读 ()

react-native  0.60以上版本安装第三方库的时候会autolink  出现这个问题是 我安装 react-native-webview 之后运行 ios出现的,这是因为ios 没有自动安装依赖库 此时:

1.  cd ios

2.  pod install

就会安装ios所需要的库  

 

类似的报错还有很多 比如:null is not an object (evaluating '_RNGestureHandlerModule.default.Direction')

这个是安装 react-navigation  的时候附带安装的  react-native-gesture-handler  还是进入ios 根目录  pod install 就可以

千万别相信网上说的再xcode工程的 liabrarys文件夹 添加依赖工程 添加完就编译报错。也不要相信  react-native link  ,如果你是0.60 以上版本。

同样类似的问题也适用 例如:

Invariant Violation: requireNativeComponent: "RNCSlider" was not found in the UIManager.

 


原文链接:https://www.cnblogs.com/allencelee/p/11218678.html
如有疑问请与原作者联系

标签:QYY文件webCOM问题

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:JS数组抽奖程序教学实例

下一篇:数据类型转换