HDU 4283---You Are the One(区间DP)

2018-06-17 23:48:38来源:未知 阅读 ()

新老客户大回馈,云服务器低至5折

题目链接

http://acm.split.hdu.edu.cn/showproblem.php?pid=4283

 

Problem Description
  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
 
Input
  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
 
Output
  For each test case, output the least summary of unhappiness .
 
Sample Input
2   
5
1 2 3 4 5
5
5 4 3 2 2
 
Sample Output
Case #1: 20
Case #2: 24
 
Source
2012 ACM/ICPC Asia Regional Tianjin Online
 
Recommend
liuyiding   |   We have carefully selected several similar problems for you:  4267 4268 4269 4270 4271 
 
题意:有n个人,输入n个基值(愤怒值)v[],表示每个人的愤怒值,现在他们依次上台表演,如果i是第k个上台,那么他的愤怒值为(k-1)*v[i]  现在有一个栈,可以让一些人进栈,让后面的人先上台表演,这样可以改变部分顺序,求所有人最小的愤怒值和;
 
思路:区间DP,定义dp[i][j]表示原序列中i到j的人的最小愤怒值的和,设i在区间i到j中第k个上场,那么i+1~i+k-1会先i上台,然后i上台,最后i+k~i+len上台,那么状态转移方程为: dp[i][j]=v[i]*(k-1)+dp[i+1][i+k-1]+(sum[i+len]-sum[i+k-1])*k+dp[i+k][i+len]  sum[]表示前缀和;
 
代码如下:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <set>
using namespace std;
const int inf=0x7fffffff;
int v[105];
int dp[105][105];
int sum[105];

int main()
{
    int T,n,Case=1;
    cin>>T;
    while(T--)
    {
        scanf("%d",&n);
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&v[i]);
            sum[i]=sum[i-1]+v[i];
        }
        for(int i=1;i<=n;i++)
            dp[i][i]=0;
        for(int len=1;len<n;len++)
        {
            for(int i=1;i+len<=n;i++)
            {   ///特判i在i~i+len的区间中是第一个和最后一个时的情况;
                dp[i][i+len]=min(sum[i+len]-sum[i]+dp[i+1][i+len],dp[i+1][i+len]+v[i]*len);
                for(int k=2;k<=len;k++)
                dp[i][i+len]=min(dp[i][i+len],v[i]*(k-1)+dp[i+1][i+k-1]+(sum[i+len]-sum[i+k-1])*k+dp[i+k][i+len]);
            }
        }
        printf("Case #%d: %d\n",Case++,dp[1][n]);
    }
}

 

标签:

版权申明:本站文章部分自网络,如有侵权,请联系:west999com@outlook.com
特别注意:本站所有转载文章言论不代表本站观点,本站所提供的摄影照片,插画,设计作品,如需使用,请与原作者联系,版权归原作者所有

上一篇:静态成员变量初始化在vs中报错“error LNK2005 static VimbaSyst

下一篇:【noi 2.5_1792】迷宫(bfs 或 dfs)